Error:2500: Invalid Reference Id, Invalid Reference Id : Line.SalesItemLineDetail.ItemRef

Keep getting this error when pushing orders to QuickBooks Online?

Error

Error:2500: [Invalid Reference Id, Invalid Reference Id : Line.SalesItemLineDetail.ItemRef]

Cause

A default setting is not correctly set, or a product mapping is not correctly set.

Resolution

  1. Visit MyWorks Sync > Settings > Defaults and make sure that your default QuickBooks shipping and coupon products are correctly set.
  2. Visit MyWorks Sync > Map > Products, and ensure your products are correctly mapped.
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