Seeing this error in the QuickBooks Web Connector as you try to connect to QuickBooks POS?
Error
You must have QuickBooks 2015 or greater to install the QuickBooks Web Connector
Cause
QuickBooks POS requires that a specific version of the Web Connector be used when connecting to it, unlike QuickBooks Desktop. As we note in our before you install documentation, this version is 2.1.0.30.
The only version of the web connector that will work when syncing with QuickBooks POS is v2.1.0.30.
Resolutions
All that's necessary is to ensure the version of the Web Connector on your QuickBooks computer is v2.1.0.30. This is usually done by either downgrading to v2.1.0.30 or uninstalling your web connector, and re-installing v2.1.0.30.
Downgrading to v2.1.0.30
- On Intuit's site, download v2.1.0.30 of the web connector.
- Close the Web Connector, and any open version of QuickBooks on your computer.
- Run the installer for v2.1.0.30 above, by right clicking it and selecting Run as Administrator.
- If the installer prompts you to repair or remove the Web Connector, first select remove, then run the installer again to run a fresh install.
- Wait for the installer to finish, and then open the web connector. It should now be v2.1.0.30.
- If it is not v2.1.0.30, proceed to the next section below.
Uninstalling, then re-installing v2.1.0.30
- On your QuickBooks computer, close the Web Connector, and any open versions of QuickBooks.
- Visit the C Drive, and delete the following folder:
- C:Program Files (x86)\Common Files\Intuit\QuickBooks - and delete the QBWebConnector folder.
- On Intuit's site, download v2.1.0.30 of the web connector.
- Run the installer for v2.1.0.30 above, by right clicking it and selecting Run as Administrator.
- Wait for the installer to finish, and then open the web connector. It should now be v2.1.0.30.