Keep getting this error when pushing customers or orders to QuickBooks Desktop using MyWorks Sync?
Error
Error Number: 0x80040400
Error: QuickBooks found an error when parsing the provided XML text stream.
Cause
The data being sent to QuickBooks Desktop most likely includes a special character that QuickBooks Desktop does not support, or a field being sent to QuickBooks exceeds the number of characters that QuickBooks supports.
Resolution Path
- Visit MyWorks Sync > Settings > Miscellaneous and change the Character Encoding to ISO-8859-1. This format is more amenable to special characters.
- If the character encoding does not resolve the issue, visit the related order in WooCommerce and review the product name. Does it have special characters in it? If so:
- Remove the special character from the product name in WooCommerce.
- If removing the special character from the name is not possible, visit MyWorks Sync > Settings > Order, and enable the option to Skip Line Item Description. This will skip syncing the product name into the QuickBooks description field.
- If the product name in WooCommerce does not contain a special character that seems to be causing the issue, review the rest of the order details in WooCommerce, like the customer name, address, email, etc.
- If they contain a special character, remove the special character from both the customer details in WooCommerce Users, and from the order details.
- If a field contains more than 25 characters, shorten it to fit this limit. The first fields to check are usually Company Name or Address 1.