Keep getting this error when pushing orders to QuickBooks Online using MyWorks Sync?
Error
Error:6140: [Duplicate Document Number Error, Duplicate Document Number Error : You must specify a different number. This number has already been used.]
Cause
A record (invoice, sales receipt, credit memo, etc) already exists in QuickBooks with the same number as the order you're attempting to push over.
This error ONLY will occur if you have the Custom Transaction Numbers setting turned on in QuickBooks, which allows you to edit transaction numbers manually.
Resolution
- Search QuickBooks for the order number that is having this error. Most likely, you'll find a record already in QuickBooks with this number.
- Remove/re-number the offending entry.
- In MyWorks Sync > Dashboard, click "Refresh Customers & Products".
- The order should push over correctly to QuickBooks.